aboutsummaryrefslogtreecommitdiff
path: root/lib/sbatch.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-05-16 21:18:27 +1000
committerJustin Bedo <cu@cua0.org>2019-05-16 21:46:02 +1000
commitd5fd734513671d957c20a66655c98d325bb1760f (patch)
treedf0ab9cf8b9806f939723cb2e0827aa047185948 /lib/sbatch.nix
parentfa35a2634108bd179de0c7dd21ca5355f6918a9b (diff)
slurm: renamed from sbatch
Diffstat (limited to 'lib/sbatch.nix')
-rw-r--r--lib/sbatch.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/lib/sbatch.nix b/lib/sbatch.nix
deleted file mode 100644
index d52c23e..0000000
--- a/lib/sbatch.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{stdenv, lib, writeScript, coreutils}:
-
-with lib;
-
-{ ppn, mem, walltime, partition ? null, slurmFlags ? null, salloc ? "/usr/bin/salloc" }:
-drv:
- let ppnReified = if drv.multicore then ppn else 1;
- in lib.overrideDerivation drv ({ args, builder, name, ... }: {
- builder = stdenv.shell;
- args = let
- script = writeScript "sbatch-script" ''
- #!${stdenv.shell}
- ${builder} ${lib.escapeShellArgs args}
- '';
-
- sbatch = writeScript "sbatch" ''
- #!${stdenv.shell}
- NIX_BUILD_CORES=${toString ppnReified}
-
- ${salloc} -c $NIX_BUILD_CORES --mem=${toString mem}G -t ${walltime} \
- -J "${name}" \
- ${optionalString (partition != null) "-p ${partition}"} \
- ${optionalString (slurmFlags != null) slurmFlags} \
- ${script}
- '';
-
- in [ "-c" sbatch ];
- })