aboutsummaryrefslogtreecommitdiff
path: root/lib/slurm.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-06-18 09:56:29 +1000
committerJustin Bedo <cu@cua0.org>2019-06-18 09:56:29 +1000
commitff8a11320db7131e488423e103937a342b82e652 (patch)
treeaeb2ed503e7017149d53535a2e5328657180219a /lib/slurm.nix
parent27d69830a9475253c239ada6c161a938c52c01f8 (diff)
slurm: fix bug with srun
salloc must call srun to actually launch job on execution node rather than submission node
Diffstat (limited to 'lib/slurm.nix')
-rw-r--r--lib/slurm.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/slurm.nix b/lib/slurm.nix
index daca4af..30a5f5e 100644
--- a/lib/slurm.nix
+++ b/lib/slurm.nix
@@ -2,7 +2,7 @@
with lib;
-{ ppn, mem, walltime, partition ? null, slurmFlags ? null, salloc ? "/usr/bin/salloc" }:
+{ ppn, mem, walltime, partition ? null, slurmFlags ? null, salloc ? "/usr/bin/salloc", srun ? "/usr/bin/srun" }:
drv:
let ppnReified = if drv.multicore then ppn else 1;
in lib.overrideDerivation drv ({ args, builder, name, ... }: {
@@ -21,7 +21,7 @@ drv:
-J "${name}" \
${optionalString (partition != null) "-p ${partition}"} \
${optionalString (slurmFlags != null) slurmFlags} \
- ${script}
+ ${srun} ${script}
'';
in [ "-c" slurm ];