aboutsummaryrefslogtreecommitdiff
path: root/lib/types.nix
diff options
context:
space:
mode:
authorl-d-s <distefano.l@wehi.edu.au>2018-11-13 09:10:23 +1100
committerl-d-s <distefano.l@wehi.edu.au>2018-11-13 09:10:23 +1100
commit2c92dd5c6425c67a18ab07eba7f15c07dbd4614a (patch)
tree46be9656b500e38bd4aa47066ce8296a127dd5bf /lib/types.nix
parent886af7beaaa98ac32db88a7453d917409cf11ae8 (diff)
parent4574deb8e1649eaf63df424585d11645c7cfa7dd (diff)
Merge branch 'master' of https://github.com/PapenfussLab/bionix
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 4dbc6ff..ef9b1b7 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -21,7 +21,8 @@ let
in
rec {
- matchFiletype = sym: y: x: if x ? filetype then match x.filetype (defError (idft sym) y filetype) else abort "unknown filetype for ${sym}";
+ matchFiletype = sym: y: x: if x ? filetype then matchFiletype' sym y x.filetype else abort "unknown filetype for ${sym}";
+ matchFiletype' = sym: y: x: match x (defError (idft sym) y filetype);
filetype = make-type "filetype" {
fa = {};
fq = {};