aboutsummaryrefslogtreecommitdiff
path: root/strip-store-paths/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2024-10-31 13:58:33 +1100
committerJustin Bedo <cu@cua0.org>2024-10-31 13:58:33 +1100
commit00d758934e7d5827e01585887a36913a326535ea (patch)
tree27fd0aea46ae380b36e43114e8b2114781aefd4f /strip-store-paths/default.nix
parent824deda0e1a7e46d4e17ff3e472dcddec220b308 (diff)
migrate zig code and target baseline cpuHEADmaster
Diffstat (limited to 'strip-store-paths/default.nix')
-rw-r--r--strip-store-paths/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/strip-store-paths/default.nix b/strip-store-paths/default.nix
index 40fb546..473df87 100644
--- a/strip-store-paths/default.nix
+++ b/strip-store-paths/default.nix
@@ -4,14 +4,15 @@ stdenv.mkDerivation {
name = "strip-store-paths";
nativeBuildInputs = [ zig ];
src = ./strip-store-paths.zig;
+
+ XDG_CACHE_HOME = "Cache";
unpackPhase = ''
cp $src strip-store-paths.zig
'';
buildPhase = ''
- export HOME=$TMPDIR
- zig build-exe -OReleaseFast strip-store-paths.zig
+ zig build-exe -OReleaseFast -mcpu=baseline strip-store-paths.zig
'';
installPhase = ''