aboutsummaryrefslogtreecommitdiff
path: root/test-tnpair.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-04 13:52:47 +1000
committerJustin Bedo <cu@cua0.org>2018-10-04 13:52:47 +1000
commit30d47b54b1e1ca63fb4a3bce26cc51a7b6017e23 (patch)
treef05c17371e10b800cb7132e446e1edc8c8b1ebc0 /test-tnpair.nix
parentd536b166aef53bc9a1c908aea1e034d255208aca (diff)
Add def function to simplify overrides
Diffstat (limited to 'test-tnpair.nix')
-rw-r--r--test-tnpair.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/test-tnpair.nix b/test-tnpair.nix
index 77b5727..f8c49ec 100644
--- a/test-tnpair.nix
+++ b/test-tnpair.nix
@@ -2,8 +2,11 @@ with (import <nixpkgs> {});
with lib;
let
- bionix = (import <bionix> {}).extend (self: super: {
- bwa = super.bwa // { index = attrs: super.bwa.index ({ flags = "-a is" ; } // attrs); };
+ bionix = (import <bionix> {}).extend (self: super: with self; {
+ bwa = with super.bwa; {
+ align = align;
+ index = def index { flags = "-a is"; };
+ };
});
in