aboutsummaryrefslogtreecommitdiff
path: root/test-tnpair.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-04 12:06:54 +1000
committerJustin Bedo <cu@cua0.org>2018-10-04 12:06:54 +1000
commitfe68926931b280aaf29808566b49b2e704e8556a (patch)
treedad0e9e11852e161c87ea6b7f4f6100a5180b9f2 /test-tnpair.nix
parent51f3817ecd2ad099b951d11e55eb3e2c516174d3 (diff)
Refactor to use bionix tree directly
Diffstat (limited to 'test-tnpair.nix')
-rw-r--r--test-tnpair.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/test-tnpair.nix b/test-tnpair.nix
index ef2af1b..77b5727 100644
--- a/test-tnpair.nix
+++ b/test-tnpair.nix
@@ -1,11 +1,19 @@
with (import <nixpkgs> {});
-with (import <bionix> {});
with lib;
let
+ bionix = (import <bionix> {}).extend (self: super: {
+ bwa = super.bwa // { index = attrs: super.bwa.index ({ flags = "-a is" ; } // attrs); };
+ });
+
+in
+
+with bionix;
+
+let
ref = ./example/ref.fa;
alignWithRG = rg: bwa.align { inherit ref; flags = "-R'@RG\\tID:${rg}\\tSM:${rg}'";};
- sort = samtools.sort { };
+ sort = samtools.sort {};
flagstat = samtools.flagstat {};
check = fastqc.check {};
callVariants = strelka.call { inherit ref; };