aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-index2.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2020-08-10 09:38:03 +1000
committerJustin Bedo <cu@cua0.org>2020-08-10 09:38:03 +1000
commitc3af7841394bbba1433a4e7e3e4aa225c697c81d (patch)
tree6f10b85b213619d714577c9ba00995b0ba6d752e /tools/bwa-index2.nix
parentc6b5b6dd77715c53acb0a19a7216e6d2cdb8dd91 (diff)
bwa2: update to release
Diffstat (limited to 'tools/bwa-index2.nix')
-rw-r--r--tools/bwa-index2.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/bwa-index2.nix b/tools/bwa-index2.nix
index f5cc69b..b02d007 100644
--- a/tools/bwa-index2.nix
+++ b/tools/bwa-index2.nix
@@ -1,5 +1,6 @@
{ bionix
, flags ? null
+, altRegex ? "^>.*_alt$"
}:
ref:
@@ -18,6 +19,7 @@ stage {
bwa-mem2 index ${optionalString (flags != null) flags} ref.fa
mkdir $out
mv ref.fa.* $out
- grep '^>[^ \t]*_alt$' ref.fa | tr -d '^>' > $out/idxbase.alt || true
+ grep -P '${altRegex}' ref.fa | tr -d '^>' > $out/idxbase.alt || true
'';
+ stripStorePaths = false;
}