aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-mem.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-29 15:32:50 +1100
committerJustin Bedo <cu@cua0.org>2018-10-29 15:32:50 +1100
commit8fb986fd88705fc01be7145b04fa229092c1e69e (patch)
tree8f5aed2499b7fc6cc1972d7a29f027c760cc1bb0 /tools/bwa-mem.nix
parent7f11fb044b6e08c53f53a1a0d0d6519fba1ccce3 (diff)
bwa-mem: BWA output is query name sorted
Diffstat (limited to 'tools/bwa-mem.nix')
-rw-r--r--tools/bwa-mem.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/bwa-mem.nix b/tools/bwa-mem.nix
index eed488e..3420294 100644
--- a/tools/bwa-mem.nix
+++ b/tools/bwa-mem.nix
@@ -36,5 +36,5 @@ in stdenv.mkDerivation {
${optionalString bamOutput "| samtools view -b"} \
> $out
'';
- passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = sort.none {};} else filetype.sam {ref = ref; sorting = sort.none {};};
+ passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = sort.name {};} else filetype.sam {ref = ref; sorting = sort.name {};};
}