aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-mem.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-24 16:35:52 +1100
committerJustin Bedo <cu@cua0.org>2018-10-25 07:26:48 +1100
commit92b4ea2ddac572f8bd830858132956829d92a734 (patch)
treea455e9f8737bcfd437063c1cb0fb498a3e309918 /tools/bwa-mem.nix
parent7daac8bb4bd0d705662c18b677a69d3785f4d8f8 (diff)
Simplify types for sorting
Diffstat (limited to 'tools/bwa-mem.nix')
-rw-r--r--tools/bwa-mem.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/bwa-mem.nix b/tools/bwa-mem.nix
index 3208e48..eed488e 100644
--- a/tools/bwa-mem.nix
+++ b/tools/bwa-mem.nix
@@ -36,5 +36,5 @@ in stdenv.mkDerivation {
${optionalString bamOutput "| samtools view -b"} \
> $out
'';
- passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = option-sort.none;} else filetype.sam {ref = ref; sorting = option-sort.none;};
+ passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = sort.none {};} else filetype.sam {ref = ref; sorting = sort.none {};};
}