aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-mem.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-11-02 16:11:29 +1100
committerJustin Bedo <cu@cua0.org>2018-11-02 16:11:29 +1100
commitceb73223717abfb0de1a0905833b0cbac0b3fa23 (patch)
treeb7b4da5ff9ff5f70c4c65fa720a5e00dbecc7b98 /tools/bwa-mem.nix
parentf416c145204765a1566782f0ff384d3f65d6ed35 (diff)
Allow bwa-mem to take gzipped fastq inputs
Diffstat (limited to 'tools/bwa-mem.nix')
-rw-r--r--tools/bwa-mem.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/bwa-mem.nix b/tools/bwa-mem.nix
index 3420294..2b3bc64 100644
--- a/tools/bwa-mem.nix
+++ b/tools/bwa-mem.nix
@@ -17,7 +17,7 @@ with bionix.compression;
let
fa = f: matchFiletype "bwa-ref" { fa = _: f; } f;
- fq = f: matchFiletype "bwa-input" { fq = _: f; } f;
+ fq = f: matchFiletype "bwa-input" { fq = _: f; gz = matchFiletype' "bwa-input" { fq = _: f; }; } f;
in stdenv.mkDerivation {
name = "bwa-mem";