aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-mem2-app.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-06-21 10:07:29 +1000
committerJustin Bedo <cu@cua0.org>2019-06-21 10:42:30 +1000
commit2ad72c4c3d33f685297ecdeb799a91afae2dccb5 (patch)
treeaa6ab7bb45a73b4cf76709eb277dccca2e4b69f1 /tools/bwa-mem2-app.nix
parent7231886ee52379de001ae830ed76a09be556ac57 (diff)
bwa-mem2: init
Diffstat (limited to 'tools/bwa-mem2-app.nix')
-rw-r--r--tools/bwa-mem2-app.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/bwa-mem2-app.nix b/tools/bwa-mem2-app.nix
new file mode 100644
index 0000000..8cca5a5
--- /dev/null
+++ b/tools/bwa-mem2-app.nix
@@ -0,0 +1,15 @@
+{ bwa, fetchFromGitHub }:
+ bwa.overrideAttrs (_:
+ {
+ name = "bwa-mem2";
+ src = fetchFromGitHub {
+ owner = "bwa-mem2";
+ repo = "bwa-mem2";
+ rev = "f882015f7f46845f72c10094a621264f78d206d8";
+ sha256 = "1wfx8j9mwbb29jw4zxp28lajmj774jy1l5x229nf065cqr2dgyqg";
+ };
+ installPhase = ''
+ mkdir -p $out/bin
+ cp bwa-mem2 $out/bin
+ '';
+ })