aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-mem2-app.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2024-10-31 13:52:24 +1100
committerJustin Bedo <cu@cua0.org>2024-10-31 13:57:42 +1100
commit824deda0e1a7e46d4e17ff3e472dcddec220b308 (patch)
treeb56acdef4dab456bbcc4a8eb81b737bfba9f004c /tools/bwa-mem2-app.nix
parent1a749d6c257f790d28587f820c901f38201dfa27 (diff)
bwa-mem2: 2.1 -> 2.2.1
Diffstat (limited to 'tools/bwa-mem2-app.nix')
-rw-r--r--tools/bwa-mem2-app.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/tools/bwa-mem2-app.nix b/tools/bwa-mem2-app.nix
index 6ee2ab4..c668dc6 100644
--- a/tools/bwa-mem2-app.nix
+++ b/tools/bwa-mem2-app.nix
@@ -1,18 +1,22 @@
{ clangStdenv, fetchFromGitHub, zlib }:
clangStdenv.mkDerivation rec {
pname = "bwa-mem2";
- version = "2.1";
+ version = "2.2.1";
+
src = fetchFromGitHub {
fetchSubmodules = true;
owner = "bwa-mem2";
repo = "bwa-mem2";
rev = "v${version}";
- sha256 = "sha256-T0nkO+NehAMFuwGi7HrQxq57gEsA16TlEWa2SHerxV4=";
+ sha256 = "sha256-2wDhtTlxIsJAlQ+Z72kmwbVqD9GZnd845eIRYMxOzgU=";
};
+
buildInputs = [ zlib ];
+
installPhase = ''
mkdir -p $out/bin
cp bwa-mem2 bwa-mem2.* $out/bin
'';
- disableHardening = [ "pie" ];
+
+ NIX_CFLAGS_COMPILE = "-Wno-register -Wno-implicit-function-declaration";
}