aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/bwa.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/bwa.nix')
-rw-r--r--tools/bwa.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/bwa.nix b/tools/bwa.nix
index 90a8bd3..6fb7d71 100644
--- a/tools/bwa.nix
+++ b/tools/bwa.nix
@@ -3,18 +3,18 @@
with bionix;
rec {
- app2 = pkgs.callPackage ./bwa-mem2-app.nix {};
+ app2 = pkgs.callPackage ./bwa-mem2-app.nix { };
/* Align read against a reference: defaults to bwa-mem */
align = bionix.bwa.mem;
/* Align reads against a reference using bwa-mem
- Type: bwa-mem :: {ref :: fasta, bamOutput :: bool, ...} -> {input1, input2} -> bam/sam
+ Type: bwa-mem :: {ref :: fasta, bamOutput :: bool, ...} -> {input1, input2} -> bam/sam
*/
mem = callBionixE ./bwa-mem.nix;
mem2 = callBionixE ./bwa-mem2.nix;
/* Creates an reference index for BWA
- Type: index :: {...} -> fasta -> BWA index
+ Type: index :: {...} -> fasta -> BWA index
*/
index = callBionixE ./bwa-index.nix;
index2 = callBionixE ./bwa-index2.nix;