aboutsummaryrefslogtreecommitdiff
path: root/tools/compression.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/compression.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/compression.nix')
-rw-r--r--tools/compression.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/tools/compression.nix b/tools/compression.nix
index 4184fec..6e69d7e 100644
--- a/tools/compression.nix
+++ b/tools/compression.nix
@@ -1,6 +1,5 @@
-{bionix, nixpkgs}:
+{bionix}:
-with nixpkgs;
with bionix;
{
@@ -12,11 +11,11 @@ with bionix;
cram = _: f;
vcf = _: f;
bed = _: f;
- gz = _: types.tagFiletype (types.gunzip f.filetype) (stdenv.mkDerivation {
+ gz = _: types.tagFiletype (types.gunzip f.filetype) (stage {
name = "gunzip";
buildCommand = "gunzip < ${f} > $out";
});
- bz2 = _: types.tagFiletype (types.bunzip2 f.filetype) (stdenv.mkDerivation {
+ bz2 = _: types.tagFiletype (types.bunzip2 f.filetype) (stage {
name = "bunzip2";
buildCommand = "bunzip2 < ${f} > $out";
});
@@ -24,7 +23,7 @@ with bionix;
gzip = f:
let
- gz = (stdenv.mkDerivation {
+ gz = (stage {
name = "gzip";
buildCommand = "gzip < ${f} > $out";
passthru = { filetype = types.filetype.gz f.filetype; };
@@ -42,7 +41,7 @@ with bionix;
bzip2 = f:
let
- bz2 = (stdenv.mkDerivation {
+ bz2 = (stage {
name = "bzip2";
buildCommand = "bzip2 < ${f} > $out";
passthru = { filetype = types.filetype.bz2 f.filetype; };