aboutsummaryrefslogtreecommitdiff
path: root/tools/crumble-app.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-28 10:26:38 +1000
committerJustin Bedo <cu@cua0.org>2018-09-28 10:26:38 +1000
commita621b614ba777c406403d18693368836a25a55f1 (patch)
treeac8961f506a4f8466f6bf0a934b4aa39a4394de7 /tools/crumble-app.nix
parentfc17098fd20b49ce72756b8eb25c7a09f2ed4434 (diff)
Add crumble
Diffstat (limited to 'tools/crumble-app.nix')
-rw-r--r--tools/crumble-app.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/crumble-app.nix b/tools/crumble-app.nix
new file mode 100644
index 0000000..fc30d5a
--- /dev/null
+++ b/tools/crumble-app.nix
@@ -0,0 +1,15 @@
+{stdenv, fetchFromGitHub, autoreconfHook, htslib}:
+
+stdenv.mkDerivation rec {
+ name = "crumble-${version}";
+ version = "git";
+
+ src = fetchFromGitHub {
+ owner = "jkbonfield";
+ repo = "crumble";
+ rev = "217fa927a5fffe7dfeed9ebf25ae78d5b513afac";
+ sha256 = "1sjgbz0dj9pszxqgkrslcdx305s50a5gyx3f5ajsnm4bynsjmv9i";
+ };
+
+ buildInputs = [ autoreconfHook htslib ];
+}