aboutsummaryrefslogtreecommitdiff
path: root/tools/crumble-toCram.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-28 10:26:38 +1000
committerJustin Bedo <cu@cua0.org>2018-09-28 10:26:38 +1000
commita621b614ba777c406403d18693368836a25a55f1 (patch)
treeac8961f506a4f8466f6bf0a934b4aa39a4394de7 /tools/crumble-toCram.nix
parentfc17098fd20b49ce72756b8eb25c7a09f2ed4434 (diff)
Add crumble
Diffstat (limited to 'tools/crumble-toCram.nix')
-rw-r--r--tools/crumble-toCram.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/crumble-toCram.nix b/tools/crumble-toCram.nix
new file mode 100644
index 0000000..6b2431f
--- /dev/null
+++ b/tools/crumble-toCram.nix
@@ -0,0 +1,15 @@
+{ stdenv
+, lib
+, callPackage
+, crumble ? callPackage ./crumble-app.nix {}
+, flags ? null}:
+
+with lib;
+
+input:
+
+stdenv.mkDerivation {
+ name = "crumble";
+ buildInputs = [ crumble ];
+ buildCommand = "crumble ${optionalString (flags != null) flags} ${input} $out";
+}