aboutsummaryrefslogtreecommitdiff
path: root/tools/fastqc-app.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-26 11:24:18 +1000
committerJustin Bedo <cu@cua0.org>2018-09-26 11:24:18 +1000
commit91e6ec3f53b9183082f56c0e52931436d069528e (patch)
treee9d7fef5af4d151f80c85a781b1bbae2ff65a92e /tools/fastqc-app.nix
parent98672cb1bba7221c5c8ecc363243cb47fcd13f47 (diff)
Add flagstat and fastqc
Diffstat (limited to 'tools/fastqc-app.nix')
-rw-r--r--tools/fastqc-app.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/fastqc-app.nix b/tools/fastqc-app.nix
new file mode 100644
index 0000000..40fd7ec
--- /dev/null
+++ b/tools/fastqc-app.nix
@@ -0,0 +1,24 @@
+{ stdenv, unzip, perl, fetchurl, jre }:
+
+stdenv.mkDerivation rec {
+ name = "fastqc-${version}";
+ version = "0.11.7";
+
+ src = fetchurl {
+ url = "https://www.bioinformatics.babraham.ac.uk/projects/fastqc/fastqc_v0.11.7.zip";
+ sha256 = "04hifbfrh60s5kzqr7n46bcviaiymr1rx67b88s3cpxydf3m1ksr";
+ };
+
+ buildInputs = [ unzip perl ];
+
+ phases = [ "unpackPhase" "installPhase" "fixupPhase" ];
+
+ installPhase = ''
+ mkdir -p $out/libexec/fastqc
+ cp -r . $out/libexec/fastqc
+ mkdir $out/bin
+ ln -s $out/libexec/fastqc/fastqc $out/bin
+ substituteInPlace $out/bin/fastqc --replace "my \$java_bin = 'java'" "my \$java_bin = '${jre}/bin/java'"
+ chmod 755 $out/libexec/fastqc/fastqc
+ '';
+}