aboutsummaryrefslogtreecommitdiff
path: root/tools/fastqc-check.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-26 11:24:18 +1000
committerJustin Bedo <cu@cua0.org>2018-09-26 11:24:18 +1000
commit91e6ec3f53b9183082f56c0e52931436d069528e (patch)
treee9d7fef5af4d151f80c85a781b1bbae2ff65a92e /tools/fastqc-check.nix
parent98672cb1bba7221c5c8ecc363243cb47fcd13f47 (diff)
Add flagstat and fastqc
Diffstat (limited to 'tools/fastqc-check.nix')
-rw-r--r--tools/fastqc-check.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/fastqc-check.nix b/tools/fastqc-check.nix
new file mode 100644
index 0000000..e13ce2a
--- /dev/null
+++ b/tools/fastqc-check.nix
@@ -0,0 +1,20 @@
+{ stdenv
+, lib
+, fastqc
+, flags ? null}:
+
+with lib;
+
+input:
+
+stdenv.mkDerivation {
+ name = "fastqc-check";
+ buildInputs = [ fastqc ];
+ buildCommand = ''
+ mkdir $out
+ fastqc \
+ -o $out \
+ ${optionalString (flags != null) flags} \
+ ${input}
+ '';
+}