aboutsummaryrefslogtreecommitdiff
path: root/tools/fastqc-check.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-04 12:06:54 +1000
committerJustin Bedo <cu@cua0.org>2018-10-04 12:06:54 +1000
commitfe68926931b280aaf29808566b49b2e704e8556a (patch)
treedad0e9e11852e161c87ea6b7f4f6100a5180b9f2 /tools/fastqc-check.nix
parent51f3817ecd2ad099b951d11e55eb3e2c516174d3 (diff)
Refactor to use bionix tree directly
Diffstat (limited to 'tools/fastqc-check.nix')
-rw-r--r--tools/fastqc-check.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/tools/fastqc-check.nix b/tools/fastqc-check.nix
index 1d9993a..17d6183 100644
--- a/tools/fastqc-check.nix
+++ b/tools/fastqc-check.nix
@@ -1,16 +1,16 @@
-{ stdenv
-, lib
-, callPackage
-, fastqc ? callPackage ./fastqc-app.nix {}
-, flags ? null}:
+{ bionix
+, nixpkgs
+, flags ? null
+}:
+with nixpkgs;
with lib;
input:
stdenv.mkDerivation {
name = "fastqc-check";
- buildInputs = [ fastqc ];
+ buildInputs = [ bionix.fastqc.fastqc ];
buildCommand = ''
mkdir $out
fastqc \