aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-callVariants.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-29 15:33:53 +1100
committerJustin Bedo <cu@cua0.org>2018-10-29 15:36:33 +1100
commite7cd661d1c5fb4135e3d436e151294e26aef9127 (patch)
tree71ef7647d15d57bc2db2cf8ec532da794fddb2fa /tools/gridss-callVariants.nix
parent8fb986fd88705fc01be7145b04fa229092c1e69e (diff)
Split gridss into constituents
Wrap each individual command for GRIDSS so that bionix executed the pipeline rather than GRIDSS. This patch introduces a "call" function that executed the whole pipeline in bionix on an arbitrary BAM file. Resolves #10.
Diffstat (limited to 'tools/gridss-callVariants.nix')
-rw-r--r--tools/gridss-callVariants.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/tools/gridss-callVariants.nix b/tools/gridss-callVariants.nix
index 799c930..416eb7c 100644
--- a/tools/gridss-callVariants.nix
+++ b/tools/gridss-callVariants.nix
@@ -23,10 +23,6 @@ assert (length (unique refs) == 1);
stdenv.mkDerivation rec {
name = "gridss-callVariants";
buildInputs = [ jre R bwa ];
- jar = fetchurl {
- url = "https://github.com/PapenfussLab/gridss/releases/download/v2.0.0/gridss-2.0.0-gridss-jar-with-dependencies.jar";
- sha256 = "01srl3qvv060whqg1y1fpxjc5cwga5wscs1bmf1v3z87dignra7k";
- };
buildCommand = ''
ln -s ${ref} ref.fa
ln -s ${bionix.samtools.faidx faidxAttrs ref} ref.fa.fai
@@ -41,7 +37,7 @@ stdenv.mkDerivation rec {
-Dsamjdk.use_async_io_write_samtools=true \
-Dsamjdk.use_async_io_write_tribble=true \
-Dgridss.gridss.output_to_temp_file=true \
- -cp ${jar} gridss.CallVariants \
+ -cp ${bionix.gridss.jar} gridss.CallVariants \
WORKER_THREADS=$NIX_BUILD_CORES \
TMP_DIR=. \
WORKING_DIR=. \