aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-collectMetrics.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/gridss-collectMetrics.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/gridss-collectMetrics.nix')
-rw-r--r--tools/gridss-collectMetrics.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/gridss-collectMetrics.nix b/tools/gridss-collectMetrics.nix
index 17e3c46..37e22f1 100644
--- a/tools/gridss-collectMetrics.nix
+++ b/tools/gridss-collectMetrics.nix
@@ -1,14 +1,13 @@
{ bionix
-, nixpkgs
, thresholdCoverage ? 10000
, flags ? null
, config ? null
, heapSize ? "1G"
}:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
input:
@@ -17,9 +16,9 @@ let
in
-stdenv.mkDerivation rec {
+stage rec {
name = "gridss-collectMetrics";
- buildInputs = [ jre R ];
+ buildInputs = with pkgs; [ jre R ];
buildCommand = ''
mkdir $out
java -Xmx${heapSize} -cp ${bionix.gridss.jar} \