aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-collectMetrics.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-29 15:33:53 +1100
committerJustin Bedo <cu@cua0.org>2018-10-29 15:36:33 +1100
commite7cd661d1c5fb4135e3d436e151294e26aef9127 (patch)
tree71ef7647d15d57bc2db2cf8ec532da794fddb2fa /tools/gridss-collectMetrics.nix
parent8fb986fd88705fc01be7145b04fa229092c1e69e (diff)
Split gridss into constituents
Wrap each individual command for GRIDSS so that bionix executed the pipeline rather than GRIDSS. This patch introduces a "call" function that executed the whole pipeline in bionix on an arbitrary BAM file. Resolves #10.
Diffstat (limited to 'tools/gridss-collectMetrics.nix')
-rw-r--r--tools/gridss-collectMetrics.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/gridss-collectMetrics.nix b/tools/gridss-collectMetrics.nix
new file mode 100644
index 0000000..4688808
--- /dev/null
+++ b/tools/gridss-collectMetrics.nix
@@ -0,0 +1,30 @@
+{ bionix
+, nixpkgs
+, thresholdCoverage ? 10000
+, flags ? null
+}:
+
+with nixpkgs;
+with lib;
+with bionix.types;
+
+input:
+
+let
+ ref = matchFiletype "gridss-collectMetrics" { bam = x: x.ref; } input;
+in
+
+
+stdenv.mkDerivation rec {
+ name = "gridss-collectMetrics";
+ buildInputs = [ jre R ];
+ buildCommand = ''
+ mkdir $out
+ java -Xmx1G -cp ${bionix.gridss.jar} \
+ gridss.analysis.CollectGridssMetrics \
+ I=${input}\
+ O=$out/input \
+ AS=true \
+ THRESHOLD_COVERAGE=${toString thresholdCoverage}
+ '';
+}