aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-computeSamTags.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/gridss-computeSamTags.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/gridss-computeSamTags.nix')
-rw-r--r--tools/gridss-computeSamTags.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/gridss-computeSamTags.nix b/tools/gridss-computeSamTags.nix
index c462461..5b249e7 100644
--- a/tools/gridss-computeSamTags.nix
+++ b/tools/gridss-computeSamTags.nix
@@ -1,5 +1,4 @@
{ bionix
-, nixpkgs
, blacklist ? null
, bwaIndexAttrs ? {}
, faidxAttrs ? {}
@@ -8,9 +7,9 @@
, heapSize ? "1G"
}:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
input:
@@ -21,9 +20,9 @@ in
assert(sorted);
-stdenv.mkDerivation rec {
+stage rec {
name = "gridss-computeSamTags";
- buildInputs = [ jre ];
+ buildInputs = with pkgs; [ jre ];
buildCommand = ''
ln -s ${ref} ref.fa
ln -s ${bionix.samtools.faidx faidxAttrs ref} ref.fa.fai