aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-identifyVariants.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-11-22 10:43:54 +1100
committerJustin Bedo <cu@cua0.org>2018-11-22 10:43:54 +1100
commit24ee2349c16f159f2627665938fd76d599055a9a (patch)
tree54a5bce88dc1403f67f58457c2b27882bc32d193 /tools/gridss-identifyVariants.nix
parent90dd48b019ff7bf9e74d202c1deace6a0896cde5 (diff)
gridss: fix configure file optional string error
Diffstat (limited to 'tools/gridss-identifyVariants.nix')
-rw-r--r--tools/gridss-identifyVariants.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/tools/gridss-identifyVariants.nix b/tools/gridss-identifyVariants.nix
index 16982e2..c91de00 100644
--- a/tools/gridss-identifyVariants.nix
+++ b/tools/gridss-identifyVariants.nix
@@ -42,26 +42,24 @@ assert (homoRef);
stdenv.mkDerivation rec {
name = "gridss-identifyVariants";
- buildInputs = [ jre ];
+ buildInputs = [ jre samtools ];
buildCommand = ''
ln -s ${ref} ref.fa
ln -s ${bionix.samtools.faidx faidxAttrs ref} ref.fa.fai
for f in ${bionix.bwa.index bwaIndexAttrs ref}/*; do
ln -s $f
done
- ${concatMapStringsSep "\n" (linkInput extractSVReads extractSVReadsAttrs) inputs}
+ ${concatMapStringsSep "\n" (linkSV) inputs}
+ ${linkSV assembly}
${concatMapStringsSep "\n" (linkInput collectMetrics collectMetricsAttrs) inputs}
${linkInput collectMetrics collectMetricsAttrs assembly}
- ASSBASE=$(basename ${assembly})
- ln -s ${assembly} $ASSBASE.gridss.working/$ASSBASE.sv.bam
- ln -s ${bionix.samtools.index {} assembly} $ASSBASE.gridss.working/$ASSBASE.sv.bai
java -Xmx4g -Dsamjdk.create_index=true \
-cp ${jar} gridss.IdentifyVariants \
REFERENCE_SEQUENCE=ref.fa \
${concatMapStringsSep " " (i: "INPUT='${i}'") inputs} \
ASSEMBLY=${assembly} \
OUTPUT_VCF=out.vcf \
- ${optionalString config ("CONFIGURATION_FILE=" + gridssConfig config)} \
+ ${optionalString (config != null) ("CONFIGURATION_FILE=" + gridssConfig config)} \
WORKING_DIR=$TMPDIR/ \
TMP_DIR=$TMPDIR/