aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-variants.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/gridss-variants.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/gridss-variants.nix')
-rw-r--r--tools/gridss-variants.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/tools/gridss-variants.nix b/tools/gridss-variants.nix
index d3070a8..fc26c5a 100644
--- a/tools/gridss-variants.nix
+++ b/tools/gridss-variants.nix
@@ -1,5 +1,4 @@
{ bionix
-, nixpkgs
, bwaIndexAttrs ? {}
, faidxAttrs ? {}
, indexAttrs ? {}
@@ -11,10 +10,10 @@
, heapSize ? "4g"
}:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
-with bionix.gridss;
+with types;
+with gridss;
inputs:
@@ -65,9 +64,9 @@ assert (all sorted inputs);
assert (homoRef);
rec {
- identify = stdenv.mkDerivation rec {
+ identify = stage rec {
name = "gridss-identifyVariants";
- buildInputs = [ jre samtools ];
+ buildInputs = with pkgs; [ jre samtools ];
buildCommand = mkLinks + ''
java -Xmx${heapSize} -Dsamjdk.create_index=true \
-cp ${jar} gridss.IdentifyVariants \
@@ -87,9 +86,9 @@ rec {
};
};
- annotate = stdenv.mkDerivation rec {
+ annotate = stage rec {
name = "gridss-annotateVariants";
- buildInputs = [ jre ];
+ buildInputs = with pkgs; [ jre ];
buildCommand = mkLinks + ''
ln -s ${bionix.gridss.identifyVariants {inherit bwaIndexAttrs faidxAttrs indexAttrs assemblyAttrs collectMetricsAttrs softClipsToSplitReadsAttrs flags config; } inputs} input.vcf
java -Xmx${heapSize} -Dsamjdk.create_index=true \