aboutsummaryrefslogtreecommitdiff
path: root/tools/kallisto-index.nix
diff options
context:
space:
mode:
authorl-d-s <distefano.l@wehi.edu.au>2018-11-13 09:10:23 +1100
committerl-d-s <distefano.l@wehi.edu.au>2018-11-13 09:10:23 +1100
commit2c92dd5c6425c67a18ab07eba7f15c07dbd4614a (patch)
tree46be9656b500e38bd4aa47066ce8296a127dd5bf /tools/kallisto-index.nix
parent886af7beaaa98ac32db88a7453d917409cf11ae8 (diff)
parent4574deb8e1649eaf63df424585d11645c7cfa7dd (diff)
Merge branch 'master' of https://github.com/PapenfussLab/bionix
Diffstat (limited to 'tools/kallisto-index.nix')
-rw-r--r--tools/kallisto-index.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/kallisto-index.nix b/tools/kallisto-index.nix
new file mode 100644
index 0000000..33dfb80
--- /dev/null
+++ b/tools/kallisto-index.nix
@@ -0,0 +1,22 @@
+{bionix
+, nixpkgs
+, kmerSize ? 31
+, unique ? false}:
+
+with nixpkgs;
+with lib;
+with bionix.types;
+
+assert (kmerSize > 1);
+
+input:
+
+assert (matchFiletype input { fa = _: true; } input);
+
+stdenv.mkDerivation {
+ name = "kallisto-index";
+ buildInputs = [ kallisto ];
+ buildCommand = ''
+ kallisto index -k ${toString kmerSize} ${optionalString unique "--make-unique"} -i $out ${input}
+ '';
+}