aboutsummaryrefslogtreecommitdiff
path: root/tools/last-align.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/last-align.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/last-align.nix')
-rw-r--r--tools/last-align.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/tools/last-align.nix b/tools/last-align.nix
index b2c8460..b326877 100644
--- a/tools/last-align.nix
+++ b/tools/last-align.nix
@@ -1,7 +1,7 @@
{ bionix
, ref
, flags ? null
-, indexAttrs ? {}
+, indexAttrs ? { }
}:
{ input1
@@ -16,10 +16,11 @@ let
fa = f: matchFiletype "last-ref" { fa = _: f; } f;
fq = f: matchFiletype "last-input" { fq = _: f; } f;
fqfa = f: matchFiletype "last-input" { fq = _: f; fa = _: f; } f;
- Q = f: matchFiletype "last-input" { fq = _: 1; fa = _: 0; } f;
- parallel = f: matchFiletype "last-input" { fq = _: "parallel-fastq"; fa = _: "parallel-fasta"; } f;
+ Q = matchFiletype "last-input" { fq = _: 1; fa = _: 0; };
+ parallel = matchFiletype "last-input" { fq = _: "parallel-fastq"; fa = _: "parallel-fasta"; };
-in stage {
+in
+stage {
name = "last-align";
buildInputs = with pkgs; [ last ];
buildCommand = ''