aboutsummaryrefslogtreecommitdiff
path: root/tools/mosdepth-depth.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/mosdepth-depth.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/mosdepth-depth.nix')
-rw-r--r--tools/mosdepth-depth.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/mosdepth-depth.nix b/tools/mosdepth-depth.nix
index 7043c43..448da11 100644
--- a/tools/mosdepth-depth.nix
+++ b/tools/mosdepth-depth.nix
@@ -1,17 +1,16 @@
{ bionix
-, nixpkgs
, indexAttrs ? {}
, flags ? null
}:
-with nixpkgs;
+with bionix;
with lib;
input:
-stdenv.mkDerivation {
+stage {
name = "mosdepth-depth";
- buildInputs = [ mosdepth ];
+ buildInputs = with pkgs; [ mosdepth ];
buildCommand = ''
mkdir $out
ln -s ${input} input.bam