aboutsummaryrefslogtreecommitdiff
path: root/tools/mutect-call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/mutect-call.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/mutect-call.nix')
-rw-r--r--tools/mutect-call.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/mutect-call.nix b/tools/mutect-call.nix
index 9fd009b..e2fe3a1 100644
--- a/tools/mutect-call.nix
+++ b/tools/mutect-call.nix
@@ -1,13 +1,12 @@
{bionix
-, nixpkgs
, cosmic
, dbsnp}:
-with nixpkgs;
+with bionix;
with lib;
let
- inherit (bionix.types) matchFiletype;
+ inherit (types) matchFiletype;
getVCFref = matchFiletype "mutect-call" {vcf = {ref}: ref;};
getBAMref = matchFiletype "mutect-call" {bam = {ref, ...}: ref;};
refs = map getVCFref [ cosmic dbsnp ];
@@ -20,7 +19,7 @@ assert (length (unique refs) == 1);
assert (ref == getBAMref normal && ref == getBAMref tumour);
-stdenv.mkDerivation {
+stage {
name = "mutect";
buildInputs = [ bionix.mutect.app ];
buildCommand = ''