aboutsummaryrefslogtreecommitdiff
path: root/tools/platypus-callVariants.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-24 07:46:23 +1100
committerJustin Bedo <cu@cua0.org>2018-10-24 07:46:23 +1100
commit94cff4f9e392911421cd8b94973b8c1e5698c430 (patch)
tree92b7565e7b7b51a6b19aeb79918161decd9ce8c8 /tools/platypus-callVariants.nix
parentc4777315bcb327e6cd1df9cc09c0afc49271769c (diff)
Fix platypus bug
Diffstat (limited to 'tools/platypus-callVariants.nix')
-rw-r--r--tools/platypus-callVariants.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/platypus-callVariants.nix b/tools/platypus-callVariants.nix
index a3e3a65..a57aa83 100644
--- a/tools/platypus-callVariants.nix
+++ b/tools/platypus-callVariants.nix
@@ -14,7 +14,7 @@ with bionix.types;
let
filename = path: last (splitString "/" path);
- getref = f: matchFiletype "platypus-callVariants" { bam = r: r; } f;
+ getref = f: matchFiletype "platypus-callVariants" { bam = {ref, ...}: ref; } f;
refs = map getref inputs;
ref = head refs;
in