aboutsummaryrefslogtreecommitdiff
path: root/tools/platypus-callVariants.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-26 10:53:53 +1000
committerJustin Bedo <cu@cua0.org>2018-09-26 10:53:53 +1000
commit98672cb1bba7221c5c8ecc363243cb47fcd13f47 (patch)
treec5c73fc08323a8350a0ba80aae7a7232fed19171 /tools/platypus-callVariants.nix
parent45af0256cf75fa28e75b6cf6874df0c48aac38cf (diff)
refactor, add mosdepth, and fixes for bwa
Diffstat (limited to 'tools/platypus-callVariants.nix')
-rw-r--r--tools/platypus-callVariants.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/tools/platypus-callVariants.nix b/tools/platypus-callVariants.nix
new file mode 100644
index 0000000..3e150d2
--- /dev/null
+++ b/tools/platypus-callVariants.nix
@@ -0,0 +1,33 @@
+{ stdenv
+, callPackage
+, lib
+, platypus
+, ref
+, index ? callPackage ./samtools-faidx.nix {}
+, bamIndex ? callPackage ./samtools-index.nix {}
+, flags ? null
+}:
+
+inputs:
+
+with lib;
+
+let filename = path: last (splitString "/" path);
+
+in stdenv.mkDerivation {
+ name = "platypus";
+ buildInputs = [ platypus ];
+ buildCommand = ''
+ ln -s ${ref} ref.fa
+ ln -s ${index ref} ref.fa.fai
+ ${concatMapStringsSep "\n" (p: "ln -s ${p} ${filename p}.bam") inputs}
+ ${concatMapStringsSep "\n" (p: "ln -s ${bamIndex p} ${filename p}.bai") inputs}
+ ls -l
+ platypus callVariants \
+ --nCPU=$NIX_BUILD_CORES \
+ --refFile=ref.fa \
+ ${optionalString (flags != null) flags} \
+ -o $out \
+ --bamFiles=${concatMapStringsSep "," (p: "${filename p}.bam") inputs}
+ '';
+}