aboutsummaryrefslogtreecommitdiff
path: root/tools/platypus-callVariants.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-04 12:06:54 +1000
committerJustin Bedo <cu@cua0.org>2018-10-04 12:06:54 +1000
commitfe68926931b280aaf29808566b49b2e704e8556a (patch)
treedad0e9e11852e161c87ea6b7f4f6100a5180b9f2 /tools/platypus-callVariants.nix
parent51f3817ecd2ad099b951d11e55eb3e2c516174d3 (diff)
Refactor to use bionix tree directly
Diffstat (limited to 'tools/platypus-callVariants.nix')
-rw-r--r--tools/platypus-callVariants.nix14
1 files changed, 6 insertions, 8 deletions
diff --git a/tools/platypus-callVariants.nix b/tools/platypus-callVariants.nix
index 3e150d2..c0204dc 100644
--- a/tools/platypus-callVariants.nix
+++ b/tools/platypus-callVariants.nix
@@ -1,10 +1,8 @@
-{ stdenv
-, callPackage
-, lib
-, platypus
+{ bionix
+, nixpkgs
, ref
-, index ? callPackage ./samtools-faidx.nix {}
-, bamIndex ? callPackage ./samtools-index.nix {}
+, indexAttrs ? {}
+, bamIndexAttrs ? {}
, flags ? null
}:
@@ -19,9 +17,9 @@ in stdenv.mkDerivation {
buildInputs = [ platypus ];
buildCommand = ''
ln -s ${ref} ref.fa
- ln -s ${index ref} ref.fa.fai
+ ln -s ${bionix.samtools.faix indexAttrs ref} ref.fa.fai
${concatMapStringsSep "\n" (p: "ln -s ${p} ${filename p}.bam") inputs}
- ${concatMapStringsSep "\n" (p: "ln -s ${bamIndex p} ${filename p}.bai") inputs}
+ ${concatMapStringsSep "\n" (p: "ln -s ${bionix.samtools.index bamIndexAttrs p} ${filename p}.bai") inputs}
ls -l
platypus callVariants \
--nCPU=$NIX_BUILD_CORES \