aboutsummaryrefslogtreecommitdiff
path: root/tools/quip-app.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-05-16 12:46:12 +1000
committerJustin Bedo <cu@cua0.org>2022-05-16 13:07:24 +1000
commit2bd2c3958ed91ef3bbea2fc3e077a8c03a648a1b (patch)
tree8d12d5f861a0ef6194fdd055586527ab998b151e /tools/quip-app.nix
parent61a05c73159f4578322ba9a59ab8ee7a5f1fb1b4 (diff)
quip: init
Diffstat (limited to 'tools/quip-app.nix')
-rw-r--r--tools/quip-app.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tools/quip-app.nix b/tools/quip-app.nix
new file mode 100644
index 0000000..422b603
--- /dev/null
+++ b/tools/quip-app.nix
@@ -0,0 +1,19 @@
+{
+ stdenv,
+ fetchFromGitHub,
+ autoreconfHook,
+ zlib,
+}:
+stdenv.mkDerivation rec {
+ name = "quip";
+
+ src = fetchFromGitHub {
+ owner = "dcjones";
+ repo = "quip";
+ rev = "9165bb5ac17a2cf2822e437df573487d7adfa1cc";
+ sha256 = "PpvgLzdiYcLyJ1JH9UzbUd29eKIlyY440HiJGYWvkrs=";
+ };
+
+ nativeBuildInputs = [autoreconfHook];
+ buildInputs = [zlib];
+}