aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-dict.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/samtools-dict.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/samtools-dict.nix')
-rw-r--r--tools/samtools-dict.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/samtools-dict.nix b/tools/samtools-dict.nix
index 80ec1e0..f9de70f 100644
--- a/tools/samtools-dict.nix
+++ b/tools/samtools-dict.nix
@@ -1,19 +1,18 @@
{ bionix
-, nixpkgs
, flags ? null
}:
input:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (matchFiletype "samtools-dict" { fa = _: true; } input);
-stdenv.mkDerivation {
+stage {
name = "samtools-dict";
- buildInputs = [ samtools ];
+ buildInputs = with pkgs; [ samtools ];
buildCommand = ''
samtools dict ${optionalString (flags != null) flags} ${input} > $out
'';