aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-faidx.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-20 13:57:12 +1000
committerJustin Bedo <cu@cua0.org>2018-09-20 14:34:36 +1000
commit33a121a7bad5b2608cc41ce60ab3d65676541fa6 (patch)
treedbbce4154a85988f3bfd9b13d42ad5d37f04e18a /tools/samtools-faidx.nix
parentf0a8a4de59ea79f56e074ddd16eff0ce1782dfe8 (diff)
Wrap some tools and make an example pipeline
Diffstat (limited to 'tools/samtools-faidx.nix')
-rw-r--r--tools/samtools-faidx.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/samtools-faidx.nix b/tools/samtools-faidx.nix
new file mode 100644
index 0000000..0dc03ee
--- /dev/null
+++ b/tools/samtools-faidx.nix
@@ -0,0 +1,18 @@
+{ stdenv
+, callPackage
+, lib
+, samtools
+, flags ? null
+}:
+
+input:
+
+with lib;
+
+stdenv.mkDerivation {
+ name = "samtools-faidx";
+ buildInputs = [ samtools ];
+ buildCommand = ''
+ samtools faidx ${optionalString (flags != null) flags} ${input} > $out
+ '';
+}