aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-fixmate.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/samtools-fixmate.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/samtools-fixmate.nix')
-rw-r--r--tools/samtools-fixmate.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/samtools-fixmate.nix b/tools/samtools-fixmate.nix
index 3ffa72c..7c62bdc 100644
--- a/tools/samtools-fixmate.nix
+++ b/tools/samtools-fixmate.nix
@@ -1,21 +1,20 @@
{ bionix
-, nixpkgs
, mateScore ? true
, flags ? null
}:
input:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (matchFiletype "samtools-fixmate" { bam = _: true; } input);
assert (matchFileSorting "samtools-fixmate" { name = _: true; } input);
-stdenv.mkDerivation {
+stage {
name = "samtools-fixmate";
- buildInputs = [ samtools ];
+ buildInputs = with pkgs; [ samtools ];
buildCommand = ''
samtools fixmate \
${optionalString mateScore "-m"} \