aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-index.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-05 16:16:20 +1000
committerJustin Bedo <cu@cua0.org>2018-10-05 16:19:06 +1000
commit871ef64f3c43199dfa01216ac86db56650c2c8a2 (patch)
tree7053b4533d7306b3fc0eed8f9bc25e8e2abb6d6e /tools/samtools-index.nix
parentdd3666f6a069105e61f8889665cf55eed9a14e51 (diff)
implement types
Diffstat (limited to 'tools/samtools-index.nix')
-rw-r--r--tools/samtools-index.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/samtools-index.nix b/tools/samtools-index.nix
index 4e09dc7..aad46a7 100644
--- a/tools/samtools-index.nix
+++ b/tools/samtools-index.nix
@@ -7,6 +7,10 @@ input:
with nixpkgs;
with lib;
+with bionix.types;
+
+assert (matchFiletype "samtools-index" { bam = _: true; } input);
+assert (matchSorting "samtools-index" { coord = _: true; } input);
stdenv.mkDerivation {
name = "samtools-index";