aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-index.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-25 08:02:20 +1100
committerJustin Bedo <cu@cua0.org>2018-10-25 08:02:20 +1100
commit99ee99c490cc109b78986181ee1be4ce1cd0c0ed (patch)
treec909b5e3d151b6542b243c261593ad4a223132f2 /tools/samtools-index.nix
parent92b4ea2ddac572f8bd830858132956829d92a734 (diff)
Improve type safety of samtools-merge
Diffstat (limited to 'tools/samtools-index.nix')
-rw-r--r--tools/samtools-index.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/samtools-index.nix b/tools/samtools-index.nix
index aad46a7..6919f97 100644
--- a/tools/samtools-index.nix
+++ b/tools/samtools-index.nix
@@ -10,7 +10,7 @@ with lib;
with bionix.types;
assert (matchFiletype "samtools-index" { bam = _: true; } input);
-assert (matchSorting "samtools-index" { coord = _: true; } input);
+assert (matchFileSorting "samtools-index" { coord = _: true; } input);
stdenv.mkDerivation {
name = "samtools-index";