aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-markdup.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-10-29 15:32:38 +1100
committerJustin Bedo <cu@cua0.org>2018-10-29 15:32:38 +1100
commit7f11fb044b6e08c53f53a1a0d0d6519fba1ccce3 (patch)
treef946a26f67f1503ee330908bbcb776537a3aeb33 /tools/samtools-markdup.nix
parent3ad53248deca12bda8351f187f322fd9bf6351a1 (diff)
init: samtools-markdup
Diffstat (limited to 'tools/samtools-markdup.nix')
-rw-r--r--tools/samtools-markdup.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/samtools-markdup.nix b/tools/samtools-markdup.nix
new file mode 100644
index 0000000..73094f2
--- /dev/null
+++ b/tools/samtools-markdup.nix
@@ -0,0 +1,22 @@
+{ bionix
+, nixpkgs
+, flags ? null
+}:
+
+input:
+
+with nixpkgs;
+with lib;
+with bionix.types;
+
+assert (matchFiletype "samtools-markdup" { bam = _: true; } input);
+assert (matchFileSorting "samtools-markdup" { coord = _: true; } input);
+
+stdenv.mkDerivation {
+ name = "samtools-markdup";
+ buildInputs = [ samtools ];
+ buildCommand = ''
+ samtools markdup ${optionalString (flags != null) flags} ${input} $out
+ '';
+ passthru.filetype = input.filetype;
+}