aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-merge.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/samtools-merge.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/samtools-merge.nix')
-rw-r--r--tools/samtools-merge.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/samtools-merge.nix b/tools/samtools-merge.nix
index eacf520..120f825 100644
--- a/tools/samtools-merge.nix
+++ b/tools/samtools-merge.nix
@@ -1,12 +1,11 @@
{ bionix
-, nixpkgs
, flags ? null
, outfmt ? null
}:
inputs:
-with nixpkgs;
+with bionix;
with lib;
let
@@ -16,9 +15,9 @@ in
assert inputIsHomogenous;
-stdenv.mkDerivation {
+stage {
name = "samtools-merge";
- buildInputs = [ samtools ];
+ buildInputs = with pkgs; [ samtools ];
buildCommand = ''
samtools merge ${optionalString (flags != null) flags} $out ${concatStringsSep " " inputs}
'';