aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-sort.nix
diff options
context:
space:
mode:
authorl-d-s <distefano.l@wehi.edu.au>2018-11-22 12:04:23 +1100
committerl-d-s <distefano.l@wehi.edu.au>2018-11-22 12:04:23 +1100
commit7c36ee4ec628767c834ad803aac76d93e31f0486 (patch)
tree2edf423614fc077c4027b7996f690b004ec4f25b /tools/samtools-sort.nix
parent3c568bacd397a3ddcb203811f7fa5a1f8af760a3 (diff)
parent0ade062d2da8a7111b14aa3d72ef7c741e98352d (diff)
Merge branch 'master' of https://github.com/PapenfussLab/bionix
Diffstat (limited to 'tools/samtools-sort.nix')
-rw-r--r--tools/samtools-sort.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/samtools-sort.nix b/tools/samtools-sort.nix
index 5a02dab..e77f3db 100644
--- a/tools/samtools-sort.nix
+++ b/tools/samtools-sort.nix
@@ -19,7 +19,7 @@ assert (matchFiletype "samtools-sort" { bam = _: true; sam = _: true; cram = _:
let
outfmtR = if outfmt != null then outfmt input else input.filetype;
outFmtFlags = matchFiletype "samtools-sort-outfmt" { bam = _: "-O BAM"; sam = _: "-O SAM"; cram = ref: "-O CRAM -T ${ref}"; } {filetype = outfmtR;};
- alreadySorted = matchFileSorting "samtools-sort" { name = _: nameSort; coord = _: !nameSort; } input;
+ alreadySorted = matchFileSorting "samtools-sort" { name = _: nameSort; coord = _: !nameSort; none = _: false;} input;
in stdenv.mkDerivation {
name = "samtools-sort";
buildInputs = [ samtools ];