aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-sort.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-11-22 10:44:16 +1100
committerJustin Bedo <cu@cua0.org>2018-11-22 10:44:16 +1100
commit98e79735080b379e9a674a69771707951bbdc1ac (patch)
treec41db53dfb85d9988f0a1338a4911c161f97aec3 /tools/samtools-sort.nix
parent24ee2349c16f159f2627665938fd76d599055a9a (diff)
samtools-sort: handle missing 'none' sorting case
Diffstat (limited to 'tools/samtools-sort.nix')
-rw-r--r--tools/samtools-sort.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/samtools-sort.nix b/tools/samtools-sort.nix
index 5a02dab..e77f3db 100644
--- a/tools/samtools-sort.nix
+++ b/tools/samtools-sort.nix
@@ -19,7 +19,7 @@ assert (matchFiletype "samtools-sort" { bam = _: true; sam = _: true; cram = _:
let
outfmtR = if outfmt != null then outfmt input else input.filetype;
outFmtFlags = matchFiletype "samtools-sort-outfmt" { bam = _: "-O BAM"; sam = _: "-O SAM"; cram = ref: "-O CRAM -T ${ref}"; } {filetype = outfmtR;};
- alreadySorted = matchFileSorting "samtools-sort" { name = _: nameSort; coord = _: !nameSort; } input;
+ alreadySorted = matchFileSorting "samtools-sort" { name = _: nameSort; coord = _: !nameSort; none = _: false;} input;
in stdenv.mkDerivation {
name = "samtools-sort";
buildInputs = [ samtools ];