aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-26 10:53:53 +1000
committerJustin Bedo <cu@cua0.org>2018-09-26 10:53:53 +1000
commit98672cb1bba7221c5c8ecc363243cb47fcd13f47 (patch)
treec5c73fc08323a8350a0ba80aae7a7232fed19171 /tools/samtools.nix
parent45af0256cf75fa28e75b6cf6874df0c48aac38cf (diff)
refactor, add mosdepth, and fixes for bwa
Diffstat (limited to 'tools/samtools.nix')
-rw-r--r--tools/samtools.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/tools/samtools.nix b/tools/samtools.nix
new file mode 100644
index 0000000..6fdbef5
--- /dev/null
+++ b/tools/samtools.nix
@@ -0,0 +1,9 @@
+{ bionix, nixpkgs }:
+
+with nixpkgs;
+
+{
+ index = attrs: callPackage ./samtools-index.nix attrs;
+ sort = attrs: callPackage ./samtools-sort.nix attrs;
+ faidx = attrs: callPackage ./samtools-faidx.nix attrs;
+}