aboutsummaryrefslogtreecommitdiff
path: root/tools/snpeff-annotate.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-02-11 09:11:36 +1100
committerJustin Bedo <cu@cua0.org>2019-02-11 09:13:00 +1100
commitbb7d6dce2f5f9ad4ebc39a80eff9e4cf66b34a28 (patch)
tree1a80963b7a79489df8f90d92932bd46b7a8dbb73 /tools/snpeff-annotate.nix
parentde57ab52a839ffbd5eee90aca29d6042b4911ed2 (diff)
snpeff: parameterise heap size and default to 31g
Diffstat (limited to 'tools/snpeff-annotate.nix')
-rw-r--r--tools/snpeff-annotate.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/snpeff-annotate.nix b/tools/snpeff-annotate.nix
index dee99f1..317d303 100644
--- a/tools/snpeff-annotate.nix
+++ b/tools/snpeff-annotate.nix
@@ -1,5 +1,6 @@
{bionix
,db
+,heapSize ? "31g"
,flags ? ""}:
input:
@@ -12,6 +13,7 @@ assert (matchFiletype "snpeff-annotate" { vcf = _: true; } input);
stage {
name = "snpeff-annotate";
buildInputs = with pkgs; [ snpeff ];
+ JAVA_TOOL_OPTIONS = "-Xmx${heapSize}";
buildCommand = ''
ln -s ${db} ${db.name}
snpeff -nodownload -dataDir $TMPDIR ${db.name} ${input} > $out