aboutsummaryrefslogtreecommitdiff
path: root/tools/snpeff-annotate.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/snpeff-annotate.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/snpeff-annotate.nix')
-rw-r--r--tools/snpeff-annotate.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/snpeff-annotate.nix b/tools/snpeff-annotate.nix
index a119c3c..dee99f1 100644
--- a/tools/snpeff-annotate.nix
+++ b/tools/snpeff-annotate.nix
@@ -1,21 +1,20 @@
{bionix
-,nixpkgs
,db
,flags ? ""}:
input:
-with nixpkgs;
-with bionix.types;
+with bionix;
+with types;
assert (matchFiletype "snpeff-annotate" { vcf = _: true; } input);
-stdenv.mkDerivation {
+stage {
name = "snpeff-annotate";
+ buildInputs = with pkgs; [ snpeff ];
buildCommand = ''
ln -s ${db} ${db.name}
snpeff -nodownload -dataDir $TMPDIR ${db.name} ${input} > $out
'';
- buildInputs = [ snpeff ];
passthru.filetype = input.filetype;
}