aboutsummaryrefslogtreecommitdiff
path: root/tools/snpeff-dbnsfp.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-04 11:37:38 +1100
committerJustin Bedo <cu@cua0.org>2019-01-08 11:02:40 +1100
commitb029bff0ec25ec06758a5fdf7c79152d2ed5c032 (patch)
treeb5671788316a5ea37e04bdbb2b0468a741e33592 /tools/snpeff-dbnsfp.nix
parent465079fb189deca9cdd08458809bcfa8e7f5eaf9 (diff)
snpeff: init
Diffstat (limited to 'tools/snpeff-dbnsfp.nix')
-rw-r--r--tools/snpeff-dbnsfp.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/snpeff-dbnsfp.nix b/tools/snpeff-dbnsfp.nix
new file mode 100644
index 0000000..f9fbdaa
--- /dev/null
+++ b/tools/snpeff-dbnsfp.nix
@@ -0,0 +1,22 @@
+{bionix
+,nixpkgs
+,dbnsfp
+,flags ? ""}:
+
+input:
+
+with nixpkgs;
+with bionix.types;
+
+assert (matchFiletype "snpeff-dbnsfp" { vcf = _: true; } input);
+
+stdenv.mkDerivation {
+ name = "snpeff-dbnsfp";
+ buildCommand = ''
+ ln -s ${dbnsfp.db} dbNSFP.txt.gz
+ ln -s ${dbnsfp.index} dbNSFP.txt.gz.tbi
+ snpeff dbnsfp -db dbNSFP.txt.gz ${input} > $out
+ '';
+ buildInputs = [ snpeff ];
+ passthru.filetype = input.filetype;
+}