aboutsummaryrefslogtreecommitdiff
path: root/tools/snpeff-dbnsfp.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/snpeff-dbnsfp.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/snpeff-dbnsfp.nix')
-rw-r--r--tools/snpeff-dbnsfp.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/snpeff-dbnsfp.nix b/tools/snpeff-dbnsfp.nix
index f9fbdaa..5e7c91a 100644
--- a/tools/snpeff-dbnsfp.nix
+++ b/tools/snpeff-dbnsfp.nix
@@ -1,16 +1,15 @@
{bionix
-,nixpkgs
,dbnsfp
,flags ? ""}:
input:
-with nixpkgs;
-with bionix.types;
+with bionix;
+with types;
assert (matchFiletype "snpeff-dbnsfp" { vcf = _: true; } input);
-stdenv.mkDerivation {
+stage {
name = "snpeff-dbnsfp";
buildCommand = ''
ln -s ${dbnsfp.db} dbNSFP.txt.gz