aboutsummaryrefslogtreecommitdiff
path: root/tools/snver-app.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-08-15 14:27:06 +1000
committerJustin Bedo <cu@cua0.org>2019-08-15 14:27:06 +1000
commit3e037c4d706f5ac02c663a8d7f56703373785d29 (patch)
treea36051c85099dc0dfa46c60b7cedb97db5c554e6 /tools/snver-app.nix
parent2117e14fe6bcef6de715974b0e34a77429b4148a (diff)
SNVer: init 0.5.3
Diffstat (limited to 'tools/snver-app.nix')
-rw-r--r--tools/snver-app.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/snver-app.nix b/tools/snver-app.nix
new file mode 100644
index 0000000..3fd30f2
--- /dev/null
+++ b/tools/snver-app.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchurl, jre, makeWrapper }:
+
+stdenv.mkDerivation rec {
+ pname = "SNVer";
+ version = "0.5.3";
+
+ src = fetchurl {
+ url = "mirror://sourceforge/snver/SNVer-${version}.tar.gz";
+ sha256 = "1y3c3gm1zdh4iz6zh1lyaaq1ks205wjm3vwx6wdsnh896xrphf5c";
+ };
+
+ buildInputs = [ makeWrapper ];
+
+ unpackPhase = ''
+ mkdir -p $out/libexec/SNVer
+ tar -zxvf $src -C $out/libexec/SNVer
+ rm -rf $out/libexec/SNVer/test
+ '';
+
+ installPhase = ''
+ mkdir $out/bin
+ makeWrapper ${jre}/bin/java $out/bin/SNVerPool --add-flags "-jar $out/libexec/SNVer/SNVerPool.jar"
+ '';
+}