aboutsummaryrefslogtreecommitdiff
path: root/tools/star-align.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2020-11-02 11:11:42 +1100
committerJustin Bedo <cu@cua0.org>2020-11-02 11:11:55 +1100
commita719ec06337643949bb0a9cbbecb7425340c49af (patch)
tree32a5403417583fa70910908d04d633f9dacd8b44 /tools/star-align.nix
parentfe1ac7b64a2a56bcd2d71dd3fd4f55912c277a86 (diff)
star: init
Diffstat (limited to 'tools/star-align.nix')
-rw-r--r--tools/star-align.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/tools/star-align.nix b/tools/star-align.nix
new file mode 100644
index 0000000..0cf9ab9
--- /dev/null
+++ b/tools/star-align.nix
@@ -0,0 +1,38 @@
+{ bionix
+, ref
+, bamOutput ? true
+, flags ? null
+, indexAttrs ? {}
+}:
+
+{ input1
+, input2 ? null
+}:
+
+with bionix;
+with lib;
+with types;
+with compression;
+
+let
+ fa = f: matchFiletype "star-ref" { fa = _: f; } f;
+ fq = f: matchFiletype "star-input" { fq = _: f; gz = matchFiletype' "star-input" { fq = _: "<(gunzip < ${f})"; }; } f;
+
+in stage {
+ name = "star-align";
+ buildInputs = with pkgs; [ star bc samtools ];
+ buildCommand = ''
+ ln -s ${fa ref} ref.fa
+ cores=$(echo $NIX_BUILD_CORES ${optionalString bamOutput "- 1"} | bc)
+ if [[ $cores -lt 1 ]] ; then
+ cores=1
+ fi
+ STAR ${optionalString (flags != null) flags} \
+ --runThreadN $cores \
+ --genomeDir ${star.index indexAttrs ref} \
+ --readFilesIn ${fq input1} ${optionalString (input2 != null) (fq input2)}
+ ${if bamOutput then "samtools view -b Aligned.out.sam > $out" else "cp Aligned.out.sam $out"}
+ '';
+ passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = sort.name {};} else filetype.sam {ref = ref; sorting = sort.name {};};
+ passthru.multicore = true;
+}