aboutsummaryrefslogtreecommitdiff
path: root/tools/star-align.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
committerJustin Bedo <cu@cua0.org>2021-10-29 17:39:01 +1100
commitbac9248a5e08e8afdf5485a6e27cfe72e1ca5090 (patch)
tree8719a280b56122017d46b582cd3da8547dd3f548 /tools/star-align.nix
parentab809b8c77efdad9fb54d3591a0193a1cbe888d1 (diff)
treewide reformatting and simplification
- simplify with statix - reformat with nixpkgs-fmt
Diffstat (limited to 'tools/star-align.nix')
-rw-r--r--tools/star-align.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/tools/star-align.nix b/tools/star-align.nix
index 44dd7f2..670c6bf 100644
--- a/tools/star-align.nix
+++ b/tools/star-align.nix
@@ -2,7 +2,7 @@
, ref
, bamOutput ? true
, flags ? null
-, indexAttrs ? {}
+, indexAttrs ? { }
}:
{ input1
@@ -18,7 +18,8 @@ let
fa = f: matchFiletype "star-ref" { fa = _: f; } f;
fq = f: matchFiletype "star-input" { fq = _: f; gz = matchFiletype' "star-input" { fq = _: "<(gunzip < ${f})"; }; } f;
-in stage {
+in
+stage {
name = "star-align";
buildInputs = with pkgs; [ star bc samtools ];
buildCommand = ''
@@ -33,6 +34,6 @@ in stage {
--readFilesIn ${fq input1} ${optionalString (input2 != null) (fq input2)}
${if bamOutput then "samtools view -b Aligned.out.sam > $out" else "cp Aligned.out.sam $out"}
'';
- passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = sort.none {};} else filetype.sam {ref = ref; sorting = sort.name {};};
+ passthru.filetype = if bamOutput then filetype.bam { inherit ref; sorting = sort.none { }; } else filetype.sam { inherit ref; sorting = sort.name { }; };
passthru.multicore = true;
}